1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1200 Enduro Fuel Sensor Failing?

Discussion in 'Multistrada' started by MotoNik, Mar 13, 2020.

  1. It's a Multistrada, so along with the barely functional rear brake (how I chuckled when I collected it from an annual service in the week and they advised me that the "health check" said my rear pads are low - oh the irony!) I'm now seeing that the fuel level is becoming slow to respond to being filled up.

    I filled up last night and over the course of the next hour of my journey the fuel level on the dash gradually rose up to showing almost full, but not quite. I specifically left the dash on while i filled up and it didn't move at all while the petrol was going in.

    So the level sensor is obviously on the way out. Two questions:

    1. Is the level sensor repairable? Is there a mechanical reason why the level sensor might be failing?
    2. Are Ducati doing any kind of goodwill replacements on these? I believe my bike is now out of warranty, and from experience of having two fail on my 2013 Multi I know they're not cheap.

    Any advice gratefully received!

    Thanks,

    Nik
     
  2. It will depend on which revision fuel level sender is in the bike. I have heard of people getting the component supplied under goodwill but they had to pay labour and you are correct, it’s a ballache, the rear of the tank needs to be lifted at least if not removed. IIRC the current version is ‘g’ but I’m sure someone who knows will chime in if I’ve got that wrong. Andy
     
  3. I can't believe that after ten years (?) they still haven't got this sorted out!
     
  4. There is a guy on utube repairing one but after you see what's involved think you will quite happily buy one. Well maybe not happy.:tired_face:
     
  5. Any idea how much they are?

    I might investigate repair - I work in the electronics industry, so have access to people who know about that sort of thing.
     
  6. Think it was around £80. What looked like a real chore was they have imbedded the base in epoxy of some kind so you have to carefully dremel around to get the bit out you want.
     
    • Thanks Thanks x 1
  7. Yup. ballache to fix, but free. New £70 or 80.
     
  8. Yes, I'm guessing lifting the tank on an enduro is several hours of hassle. Probably somewhat reminiscent of the hideous old 1000DS I had.
     
  9. Don't have the Enduro but just replaced mine in a 2015 dvt. I ran the tank very low and lifted the rear with a board. Didn't disconnect anything. The sensor unscrews with a channel lock pliers. Undo one connector. Install new sensor in reverse order, there is no special sealant or epoxy to deal with. It's reads more accurate than the original and starts working immediately, no electronic dash resets or dealer visit.

    About $100 for me I get a discount at dealer.
    1/2 hour job.
    I was out of warranty, Ducati refused to replace.
    Ducati already replaced one in warranty free of charge.
     
    • Thanks Thanks x 1
  10. Ducati replaced mine, I'd definitely try the good will route first.

    After all it's a known issue.

    Try to use only Chevron/Exxon fuel.
     
  11. Why do you propose using specific fuel? Just curious, as I only ever buy the cheapest supermarket fuel for all my vehicles, and always have.
     
  12. In the US, they have high ethanol content and it messes with the tanks.
    I only put in the full fat fuel in the bike. Makes it perform better. Each to their own though.
     
  13. Looking at the pumps this morning, both the 99 and 95 octane fuel are both rated at E5, so no difference (except price).

    Strange anomaly - I left the ignition on to see if the gauge moved as I filled up. Walked in to pay the cashier and came back to the bike and it had switched itself off. Turned it back on and the hazards were going. Turned it off and on again and it was back to normal - maybe that was a visual reminder? After I set off I found my cruise control wouldn't activate, although after turning the bike off and on again it was fine. Software bug perhaps?
     
  14. Oh, and leaving the ignition on was a waste of time - it didn't register the fuel going in, and the gauge gradually rose as I rode, although never actually showing full. It seems like it's so slow to respond that by the time it might show full I've done 40 miles and used X number of litres anyway.
     
  15. From what I've read it appears the float gets distorted, swollen or similar and then either sticks in one position or is very slow to react. It's been a problem since the early days with all multis.

    One of mine jammed as I accelerated hard away from some lights (a Porsche driver might have been involved). The tank was about a third full but then showed empty and when I filled up it didn't move.
     
  16. I didn't realise it had a float, I had assumed it was some sort of electrickery. As a mechanical engineer I now feel more inclined than ever to go exploring.
     
  17. #17 Twin4me, Mar 17, 2020
    Last edited: Mar 17, 2020
  18. Did a bit of research, and sure enough there is a float which triggers contacts in a long thin PCB. Evidently the issue can either be solder joints in the PCB or the float swelling and getting stuck...or both!

    Seems like it may be possible to improve the design, and a failed sensor might be fixable. I'll wait for mine to pack up completely before looking at it. In the meantime I might look at buying a secondhand one and having a play.
     
    • Like Like x 1
  19. Nik, I don't think you need to take the tank off for an enduro. I think (though could be wrong) the fuel level sensor is on the top right of the tank. You need to remove the painted tank cover, which means seat, both metal sides off, and the black plastic finishers. I can't recall if you have to take the plastic carrier bits off that are under the metal sides.
    Either way, its pretty easy to get all those side bits off. The painted tank cover can be a pain because of the way it fits over the fuel filler. Oh, and there is a screw at the bottom back left that is inside the panel and easy to miss, plus a pain to get to.

    Getting the tank itself off is not too much of a nightmare, just make sure it is pretty empty. I posted details on here a while ago when I took mine off. Hardest part was getting the bleedin fuel pipe out of the pump :yum

    Let us know how you get on, my 2012 multi's fuel sender has started acting like yours too.
     
  20. Nice one, thanks John. It'll stay put for now, but eventually I suspect it'll annoy me enough to want to fix it. Appreciate your detailed reply!
     
    • Like Like x 1

Do Not Sell My Personal Information