1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1200 Steering Lock Stopped Working

Discussion in 'Multistrada' started by pl2112, Aug 1, 2016.

  1. Per the thread title mine has just stopped working after working perfectly up to now.
    When I switch off and turn the handlebars fully to the left or right I don’t get the “WAITING FOR LOCK” message in the round display.

    Suggests it is likely that the switch on the end of the small levers that you can see behind the headstock that detects the position of the handlebars has failed. Just wondering if anyone else has had a similar problem and whether the switch is replaceable or integrated in the hands free switch?

    Any help appreciated.
     
  2. i was speaking to the nice chap at Almax last week and he said he doesnt know why people bother with them anymore

    a) theyre not a deterrent to bike thieves and
    b) if youre lucky enough to have an attempted theft and still have the bike in your own hands afterwards, you're going to be left with a hefty bill for fixing something that a small child could break in an instant

    (im not sure our insurance companies would agree like but it made sense to me)
     
    • Like Like x 1
  3. It's a known issue, talk to your local dealer . Andy
     
  4. But the bike is 2 1/2 years outside warranty and I'm quite capable of fixing stuff without paying dealer prices.
     
  5. ..which is why I never use mine.
     
  6. MCE insurance insist on mine being activated otherwise........!
     
    • Like Like x 1
  7. Know fault that might be resolved with goodwill even out of warranty, don't know till you ask. Workshop may also be able to confirm what the problem is. Always helps to have a good relationship with your local dealer. Andy
     
    #7 Android853sp, Aug 1, 2016
    Last edited: Aug 1, 2016
  8. that deserves a face palm all of its own!! ;p

    The days I worry about what an insurance company thinks are long gone especially those who write of motorbikes for their own personal benefit for the sake of a few scratched bar ends.

    Slight off down the road at 10mph = Cat C write off.


    “Hiya mate ive just had my bike stolen”


    “Did it have the steering lock on?”


    “Of course it did” etc etc ,
     
  9. Hi all, wasn't a member yet. But am reading this forum since buying a multi.

    @pl2112

    My diavel had more or less the same problem, it didn't sense the feelers anymore. The dealership wanted to exchange the entire system for around €800, I declined ;) sorta thought I could live without the steering lock.

    Some months later ducati brought out a new firmware for the diavel that fixed exactly that issue, my steering lock started to work once again.... Go figure..
     
  10. A good point. I had a 6 day old Fireblade pinched in 1996 and they had broken the headstock mounted, lock lug off. That required a new frame and the bike was an insurance write off - ridiculous!!
     
    • Like Like x 1
  11. Can’t get mine to work, 2010 1200s just get the “waiting for lock message”
    Any ideas?
     
  12. On my old 2013 I used to ensure a covering of ACF50 went down and around the whole mechanism, and as a result none of the moving parts ever failed with everyday use all year round, so if something is seized that might help but if it’s failed it’s replacements...worth a shot if you have some, but let it work for a time cos it creeps.

    Hope it comes good :upyeah:
     
  13. You got the bars turned round fully? If not, it won't lock.
     
  14. Yep, I’ve tried everything all day, both full lock left & right, totally baffled!
     


  15. Hands Free software change, then steering lock limit switch out of operation (as MY 2013+14 standard)
    Ducati software RS SAT 876
     
  16. Is that something I need to get done at a Ducati dealer? & I have to pay?
    How much?
     

  17. yes ducati dealer, 2018 i paid 35€
     
    • Like Like x 1
  18. Had that software installed to My MTS 2010. I think it is the Ducati official way of dealing with the problem. Working flawless now for 5-6 years. Stearing lock itself was replaced twice during THE warranty period. So that definitely is a weak part
     
    • Like Like x 1
  19. It definitely doesn’t work, I’ve tried everything & it just says waiting for lock..
     
  20. So it sounds from what various folks are saying that it's worth squirting some lube into the mechanism.
     
    • Like Like x 1

Do Not Sell My Personal Information